aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6c5d947..11d3e17 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,9 +1,9 @@
lib_LTLIBRARIES = libiperf.la # Build and install an iperf library
bin_PROGRAMS = iperf3 # Build and install an iperf binary
if ENABLE_PROFILING
-noinst_PROGRAMS = t_timer t_units t_uuid t_api iperf3_profile # Build, but don't install the test programs and a profiled version of iperf3
+noinst_PROGRAMS = t_timer t_units t_uuid t_api t_auth iperf3_profile # Build, but don't install the test programs and a profiled version of iperf3
else
-noinst_PROGRAMS = t_timer t_units t_uuid t_api # Build, but don't install the test programs
+noinst_PROGRAMS = t_timer t_units t_uuid t_api t_auth # Build, but don't install the test programs
endif
include_HEADERS = iperf_api.h # Defines the headers that get installed with the program
@@ -84,6 +84,11 @@ t_api_CFLAGS = -g
t_api_LDFLAGS =
t_api_LDADD = libiperf.la
+t_auth_SOURCES = t_auth.c
+t_auth_CFLAGS = -g
+t_auth_LDFLAGS =
+t_auth_LDADD = libiperf.la
+
# Specify which tests to run during a "make check"
@@ -91,6 +96,7 @@ TESTS = \
t_timer \
t_units \
t_uuid \
- t_api
+ t_api \
+ t_auth
dist_man_MANS = iperf3.1 libiperf.3