aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@profusion.mobi>2011-12-08 05:17:43 -0200
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2011-12-08 11:17:16 -0200
commit1487a64ffa39cc9fdbac990e6e64658f21d67f16 (patch)
treea30e166d3efc1b5b1f0124e6743a7440261ff882 /Makefile.am
parente005facdb9bc99a3aacb55c23260464fb31e25d0 (diff)
downloadkmod-1487a64ffa39cc9fdbac990e6e64658f21d67f16.tar.gz
add kmod_module_get_filtered_blacklist()
This function will filter the given list against the known blacklist, returning a new list with remaining modules with the reference incremented.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index da91e5c..b6ba9d8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,7 @@ test_test_loaded_LDADD = libkmod/libkmod.la
noinst_PROGRAMS = test/test-insmod test/test-rmmod test/test-rmmod2 \
test/test-lookup test/test-path-from-name \
test/test-get-dependencies test/test-mod-double-ref \
+ test/test-blacklist \
$(check_PROGRAMS)
test_test_rmmod_SOURCES = test/test-rmmod.c
@@ -82,3 +83,6 @@ test_test_get_dependencies_LDADD = libkmod/libkmod.la
test_test_mod_double_ref_SOURCES = test/test-mod-double-ref.c
test_test_mod_double_ref_LDADD = libkmod/libkmod.la
+
+test_test_blacklist_SOURCES = test/test-blacklist.c
+test_test_blacklist_LDADD = libkmod/libkmod.la