aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2011-12-06 02:40:38 -0200
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2011-12-06 03:34:51 -0200
commit1843b153b458e57db6309e7d43a29c6b82bb9d5f (patch)
tree989691d7461658c338fc732ed713f9c1072e2903 /Makefile.am
parentc5b5ea9c7c4722ce33d1abb8cbee0d87bc99806a (diff)
downloadkmod-1843b153b458e57db6309e7d43a29c6b82bb9d5f.tar.gz
test: add test to get dependencies of a module
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f4ed47b..f6534ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,8 @@ test_test_loaded_SOURCES = test/test-loaded.c
test_test_loaded_LDADD = libkmod/libkmod.la
noinst_PROGRAMS = test/test-insmod test/test-rmmod test/test-rmmod2 \
- test/test-lookup test/test-path-from-name $(check_PROGRAMS)
+ test/test-lookup test/test-path-from-name \
+ test/test-get-dependencies $(check_PROGRAMS)
test_test_rmmod_SOURCES = test/test-rmmod.c
test_test_rmmod_LDADD = libkmod/libkmod.la
@@ -73,3 +74,6 @@ test_test_lookup_LDADD = libkmod/libkmod.la
test_test_path_from_name_SOURCES = test/test-path-from-name.c
test_test_path_from_name_LDADD = libkmod/libkmod.la
+
+test_test_get_dependencies_SOURCES = test/test-get-dependencies.c
+test_test_get_dependencies_LDADD = libkmod/libkmod.la