aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2011-12-05 23:17:29 -0200
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2011-12-06 03:34:51 -0200
commitc5b5ea9c7c4722ce33d1abb8cbee0d87bc99806a (patch)
tree4c5b2faeac067432a781b72caf291fb5934ec94c /Makefile.am
parent4f2bb7cdd4c0b77f09f6f79b2c92683fdcdfa163 (diff)
downloadkmod-c5b5ea9c7c4722ce33d1abb8cbee0d87bc99806a.tar.gz
test: add test to convert name to path
If we create a kmod_module from a name, the path returned is relative to the module dirname, as passed during kmod_ctx creation. Note that if kmod_ctx is created with kmod_new(NULL), the dir used is the one returned by uname.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 950da23..f4ed47b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,7 @@ test_test_loaded_SOURCES = test/test-loaded.c
test_test_loaded_LDADD = libkmod/libkmod.la
noinst_PROGRAMS = test/test-insmod test/test-rmmod test/test-rmmod2 \
- test/test-lookup $(check_PROGRAMS)
+ test/test-lookup test/test-path-from-name $(check_PROGRAMS)
test_test_rmmod_SOURCES = test/test-rmmod.c
test_test_rmmod_LDADD = libkmod/libkmod.la
@@ -70,3 +70,6 @@ test_test_insmod_LDADD = libkmod/libkmod.la
test_test_lookup_SOURCES = test/test-lookup.c
test_test_lookup_LDADD = libkmod/libkmod.la
+
+test_test_path_from_name_SOURCES = test/test-path-from-name.c
+test_test_path_from_name_LDADD = libkmod/libkmod.la