aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2011-11-23 17:22:09 -0200
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2011-11-23 17:22:09 -0200
commiteee1345cf24fcd21efcef907aec2ded4cca98874 (patch)
tree152c199f678a0c274e1b771d8b7e5b21115e90dc /Makefile.am
parent6806a0437f49e97969872a353473b23d27a0e380 (diff)
downloadkmod-eee1345cf24fcd21efcef907aec2ded4cca98874.tar.gz
Add binary to test rmmod feature
It doesn't run with `make check' since o It's dangerous o It needs to be run as root o It needs an argument, otherwise it removes the first module with use_count==0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 929de86..a55a03a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,9 +45,13 @@ pkgconfig_DATA = libkmod/libkmod.pc
TESTS = test/test-init test/test-loaded
-check_PROGRAMS = test/test-init test/test-loaded
+check_PROGRAMS = test/test-init test/test-loaded test/test-rmmod
test_test_init_SOURCES = test/test-init.c
test_test_init_LDADD = libkmod/libkmod.la
test_test_loaded_SOURCES = test/test-loaded.c
test_test_loaded_LDADD = libkmod/libkmod.la
+
+noinst_PROGRAMS = test/test-rmmod $(check_PROGRAMS)
+test_test_rmmod_SOURCES = test/test-rmmod.c
+test_test_rmmod_LDADD = libkmod/libkmod.la