aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVictor Hsieh <victorhsieh@google.com>2020-12-15 13:59:26 -0800
committerVictor Hsieh <victorhsieh@google.com>2021-01-08 08:25:09 -0800
commit5cc8a92ff386267e0c69f7dad909f5cc3132ebb9 (patch)
treeadf0ed37ac7d7272ca7ba5c1ed11a742e0f3bed6 /Cargo.toml
parent4061c0fb78928db1e424afbaf808d36800fbbfe7 (diff)
downloadlibchromeos-rs-5cc8a92ff386267e0c69f7dad909f5cc3132ebb9.tar.gz
Import libchromeos-rs
This change is imported from the libchromeos-rs directory of https://chromium.googlesource.com/chromiumos/platform2 Extra files added: - Android.bp - patches/Android.bp.patch File modified: - OWNERS Bug: 174797066 Test: mma Change-Id: I473686bb8dd9633759e6fb58266c9750322d52f2
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..d0de4ce
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "libchromeos"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+edition = "2018"
+
+[dependencies]
+data_model = { path = "../crosvm/data_model" } # provided by ebuild
+libc = "0.2"
+log = "0.4"
+protobuf = "2.1"
+intrusive-collections = "0.9"
+futures = { version = "0.3", default-features = false, features = ["alloc"] }
+
+[dev-dependencies]
+futures = { version = "0.3", features = ["async-await"] }
+futures-executor = { version = "0.3", features = ["thread-pool"] }
+futures-util = "0.3"
+