aboutsummaryrefslogtreecommitdiff
path: root/examples/c++/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/c++/Makefile.am')
-rw-r--r--examples/c++/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/c++/Makefile.am b/examples/c++/Makefile.am
new file mode 100644
index 0000000..46b66d0
--- /dev/null
+++ b/examples/c++/Makefile.am
@@ -0,0 +1,16 @@
+
+check_PROGRAMS = example1 example2 example3 example4
+AM_DEFAULT_SOURCE_EXT = .cpp
+
+noinst_PROGRAMS=$(check_PROGRAMS)
+TESTS = $(check_PROGRAMS)
+XFAIL_TESTS = example4
+
+AM_CPPFLAGS = -I $(top_srcdir)/lib
+
+LDADD = $(top_builddir)/lib/libconfig++.la
+
+EXTRA_DIST = \
+ example.cfg invalid.cfg \
+ *.vcproj \
+ *.vcxproj