aboutsummaryrefslogtreecommitdiff
path: root/tinytest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tinytest/CMakeLists.txt')
-rw-r--r--tinytest/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tinytest/CMakeLists.txt b/tinytest/CMakeLists.txt
new file mode 100644
index 0000000..3896e66
--- /dev/null
+++ b/tinytest/CMakeLists.txt
@@ -0,0 +1,17 @@
+add_library(libtinytest STATIC
+ tinytest.c tinytest.h)
+
+target_include_directories(libtinytest
+ PUBLIC
+ $<INSTALL_INTERFACE:.>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
+)
+
+if(CMAKE_HOST_WIN32)
+ if(MSVC)
+ set_target_properties(libtinytest
+ PROPERTIES
+ COMPILE_FLAGS "/wd4996"
+ )
+ endif()
+endif()