summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorRobert Ginda <rginda@google.com>2015-08-10 15:45:03 -0700
committerRobert Ginda <rginda@google.com>2015-08-10 15:45:03 -0700
commit4340b1831d360a440ab7bf5e1aa0170398437163 (patch)
treef5a90fac0006dada785191bc4e626982b62131e7 /examples/Makefile.am
parentd012a8bd96e5ae970e89b181ae352c909adf506a (diff)
parent8d8ad60fce9134f31b233c78bd286d3f949aa3b8 (diff)
downloadlibdaemon-4340b1831d360a440ab7bf5e1aa0170398437163.tar.gz
Import libdaemon into the Android tree.
Import libdaemon (a dep of external/avahi, which is a dep of system/peerd). At the time of the import the libdaemon HEAD was 0630da04e575213229f695bdc3dc90aa92ca4f55 Committed on 2012-09-03. Bug: 22921222
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 0000000..930c3bf
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,28 @@
+# This file is part of libdaemon.
+#
+# Copyright 2003-2008 Lennart Poettering
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+noinst_PROGRAMS = testd
+
+AM_CPPFLAGS=-I$(top_srcdir)
+
+testd_SOURCES=testd.c
+testd_LDADD=../libdaemon/libdaemon.la