aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2013-12-11 16:25:48 -0800
committerEric Anholt <eric@anholt.net>2013-12-11 17:18:28 -0800
commit847ba1acdfc2c80f4e4dc5c3b69b6ff9e02af85f (patch)
tree4d788d10cf0ea2f7a1b6c591dd7335ffef079f83 /configure.ac
parent6c0e0423f697531927568bd7668d0818594baf91 (diff)
downloadlibepoxy-847ba1acdfc2c80f4e4dc5c3b69b6ff9e02af85f.tar.gz
Add an appropriate error message if libX11 is missing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2031414..5b61ace 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,10 @@ esac
AC_SUBST([VISIBILITY_CFLAGS])
PKG_CHECK_MODULES(X11, [x11], [x11=yes], [x11=no])
+if test x$x11 = xno -a x$build_glx = xyes; then
+ AC_MSG_ERROR([libX11 headers (libx11-dev) required to build with GLX support])
+fi
+
AM_CONDITIONAL(HAVE_X11, test x$x11 = xyes)
PKG_CHECK_MODULES(GL, [gl], [gl=yes], [gl=no])