aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 6 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 91d9792..e1d8d8b 100644
--- a/meson.build
+++ b/meson.build
@@ -1,11 +1,11 @@
-project('libepoxy', 'c', version: '1.5.4',
+project('libepoxy', 'c', version: '1.5.10',
default_options: [
'buildtype=debugoptimized',
'c_std=gnu99',
'warning_level=1',
],
license: 'MIT',
- meson_version: '>= 0.47.0')
+ meson_version: '>= 0.54.0')
epoxy_version = meson.project_version().split('.')
epoxy_major_version = epoxy_version[0].to_int()
@@ -95,6 +95,7 @@ if cc.get_id() == 'msvc'
'-we4053', # an expression of type void was used as an operand
'-we4071', # no function prototype given
'-we4819', # the file contains a character that cannot be represented in the current code page
+ '/utf-8', # Set the input and exec encoding to utf-8, like is the default with GCC
]
elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
test_cflags = [
@@ -165,9 +166,11 @@ endif
dl_dep = cc.find_library('dl', required: false)
gl_dep = dependency('gl', required: false)
egl_dep = dependency('egl', required: false)
+elg_headers_dep = egl_dep.partial_dependency(compile_args: true, includes: true)
# Optional dependencies for tests
x11_dep = dependency('x11', required: false)
+x11_headers_dep = x11_dep.partial_dependency(compile_args: true, includes: true)
# GLES v2 and v1 may have pkg-config files, courtesy of downstream
# packagers; let's check those first, and fall back to find_library()
@@ -196,14 +199,8 @@ if host_system == 'windows'
gdi32_dep = cc.find_library('gdi32', required: true)
endif
-# Python
-python = import('python3').find_python()
-if not python.found()
- python = find_program('python', required: true)
-endif
-
# Generates the dispatch tables
-gen_dispatch_py = files('src/gen_dispatch.py')
+gen_dispatch_py = find_program('src/gen_dispatch.py')
gl_registry = files('registry/gl.xml')
egl_registry = files('registry/egl.xml')