aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTom Callaway <spot@fedoraproject.org>2020-09-14 04:45:02 -0400
committerGitHub <noreply@github.com>2020-09-14 09:45:02 +0100
commit5b901ee0315658035661332d6d85d8bfd8816b6b (patch)
tree9df3ec7e632eea5da6221af7e9363583c28affc2 /meson.build
parentd7d08595e2c354d4c7245e3986ceed353d336ff5 (diff)
downloadlibfuse-5b901ee0315658035661332d6d85d8bfd8816b6b.tar.gz
Fix compilation for compilers not supporting __has_attribute
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index b2b85da..e83d441 100644
--- a/meson.build
+++ b/meson.build
@@ -95,8 +95,12 @@ endif
# it is safe for this check to fail and for us to fallback to the old _asm_
# method for symver
code = '''
-#if defined __has_attribute && !__has_attribute (symver)
-#error symver attribute not supported
+#if defined __has_attribute
+# if !__has_attribute (symver)
+# error symver attribute not supported
+# endif
+#else
+#error __has_attribute not defined, assume we do not have symver
#endif
int main(void) {