aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLiu Bo <liub.liubo@gmail.com>2019-04-18 01:55:42 -0700
committerNikolaus Rath <Nikolaus@rath.org>2019-04-18 09:55:42 +0100
commit5fc562c90d7925963467babbb73ae5b4f9fd13f8 (patch)
tree40520fcf13262c62937db332958997ed86edf550 /meson.build
parent9ec8e1c9406451262b6fd3c93787b2bb6d745ea5 (diff)
downloadlibfuse-5fc562c90d7925963467babbb73ae5b4f9fd13f8.tar.gz
Add fallocate and use it instead of posix_fallocate if possible (#398)
fuse.ko has supported FALLOC_FL_KEEP_SIZE and FALLOC_FL_PUNCH_HOLE at this moment and more modes may be supported in the future. fallocate(2) supports modes while posix_fallocate(2) does not, so this makes lo_fallocate use fallocate(2) instead. Signed-off-by: Liu Bo <bo.liu@linux.alibaba.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9c35745..5797fec 100644
--- a/meson.build
+++ b/meson.build
@@ -36,7 +36,7 @@ cfg.set_quoted('PACKAGE_VERSION', meson.project_version())
# Test for presence of some functions
test_funcs = [ 'fork', 'fstatat', 'openat', 'readlinkat', 'pipe2',
'splice', 'vmsplice', 'posix_fallocate', 'fdatasync',
- 'utimensat', 'copy_file_range' ]
+ 'utimensat', 'copy_file_range', 'fallocate' ]
foreach func : test_funcs
cfg.set('HAVE_' + func.to_upper(),
cc.has_function(func, prefix: include_default, args: args_default))