aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index b2b85da..e83d441 100644
--- a/meson.build
+++ b/meson.build
@@ -95,8 +95,12 @@ endif
# it is safe for this check to fail and for us to fallback to the old _asm_
# method for symver
code = '''
-#if defined __has_attribute && !__has_attribute (symver)
-#error symver attribute not supported
+#if defined __has_attribute
+# if !__has_attribute (symver)
+# error symver attribute not supported
+# endif
+#else
+#error __has_attribute not defined, assume we do not have symver
#endif
int main(void) {