aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-04-01 00:37:20 +0000
committerDRC <dcommander@users.sourceforge.net>2011-04-01 00:37:20 +0000
commitdffd53da5da0902b3b48e1ef871911cd81a2cc39 (patch)
tree79dfb7b78b2d17c5240e2a3dfcae066157b94466 /Makefile.am
parentf2602ce567dd6d0d33bbb3af9d7393f8a0bcd0e3 (diff)
downloadlibjpeg-turbo-dffd53da5da0902b3b48e1ef871911cd81a2cc39.tar.gz
Fix 'make dist' so that it includes only what we need from java/ (it was errantly including java/Makefile)
git-svn-id: svn+ssh://svn.code.sf.net/p/libjpeg-turbo/code/trunk@550 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b06da6ec..281159e9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,16 +37,16 @@ endif
libturbojpeg_la_SOURCES = $(libjpeg_la_SOURCES) turbojpegl.c turbojpeg.h \
transupp.c transupp.h
+SUBDIRS = java
+
if WITH_JAVA
-SUBDIRS = java
libturbojpeg_la_SOURCES += turbojpeg-jni.c
libturbojpeg_la_CFLAGS = ${JNI_CFLAGS}
TJMAPFILE = turbojpeg-mapfile.jni
else
-SUBDIRS =
TJMAPFILE = turbojpeg-mapfile
endif
@@ -126,7 +126,7 @@ TESTFILES= testorig.jpg testorig.ppm testimg.bmp testimgflt.jpg \
testimgint.ppm testimgflt-nosimd.jpg testimgcrop.jpg testimgari.jpg \
testimgari.ppm testimgfst100.jpg testimggray.jpg
-EXTRA_DIST = win release java $(DOCS) $(TESTFILES) CMakeLists.txt \
+EXTRA_DIST = win release $(DOCS) $(TESTFILES) CMakeLists.txt \
sharedlib/CMakeLists.txt cmakescripts libjpeg.map.in
dist-hook: