aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLinus Walleij <triad@df.lth.se>2011-11-16 23:44:58 +0100
committerLinus Walleij <triad@df.lth.se>2011-11-16 23:44:58 +0100
commit7cf02643117f11ab3c7d11dd49c1fc9d1776ba4e (patch)
treeb583f25bd344aa3ada0f34bb4c2eb582d1019bc9 /configure.ac
parentd6f25baf36fba05e3d8b2fa6d3cd4c026e2e6d33 (diff)
downloadlibmtp-7cf02643117f11ab3c7d11dd49c1fc9d1776ba4e.tar.gz
Revert "Rewrite libmtp to use libusb1, drop legacy libusb support."
This reverts commit c9105ab04321f5dce1f15cd5d152d2d63820cd2d. Conflicts: configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index abb414d..e0eb607 100644
--- a/configure.ac
+++ b/configure.ac
@@ -111,15 +111,11 @@ fi
AM_CONDITIONAL(MS_LIB_EXE, test x$ms_lib_exe = xyes)
# Checks for libraries.
-AC_CHECK_LIB([usb-1.0], [libusb_init],,[
- AC_CHECK_LIB([usb], [usb_control_msg],,
- AC_MSG_ERROR([I can't find the libusb-1.0 library on your system. You
- may need to set the LDFLAGS environment variable to include the
- search path where you have libusb installed before running
- configure (e.g. setenv LDFLAGS=-L/usr/local/lib)]),
- "$OSFLAGS"
- )
-],"$OSFLAGS")
+AC_CHECK_LIB([usb], [usb_control_msg],,
+ AC_MSG_ERROR([I can't find the libusb libraries on your system. You
+ may need to set the LDFLAGS environment variable to include the
+ search path where you have libusb installed before running
+ configure (e.g. setenv LDFLAGS=-L/usr/local/lib)]), "$OSFLAGS")
# Checks for header files.
AC_HEADER_STDC