summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authord0u9 <d0u9.su@outlook.com>2018-03-23 21:21:11 +0800
committerThomas Haller <thaller@redhat.com>2018-06-25 14:39:41 +0200
commitddfc36f46e2d1581e2b08bbe167644bd8b1f1571 (patch)
treeed21ede97a53822c1086701c3d79b59adc7018a6 /Makefile.am
parent3ebb0ea66b165d061c287164ca4514c13f8b2772 (diff)
downloadlibnl-ddfc36f46e2d1581e2b08bbe167644bd8b1f1571.tar.gz
Add support for cloning cgroup filter object.
In this commit, we implement ematch_tree_clone(), which is basis of cgroup_clone() interface. The whole ematch tree is deep-copied except the e_ops filed. Also, a new unit test is added for testing the interface, which named as check-ematch-tree-clone.c located in tests directory. https://github.com/thom311/libnl/pull/176
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 98b0c5e4..8e7180e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -898,7 +898,8 @@ tests_check_all_SOURCES = \
tests/util.h \
tests/check-all.c \
tests/check-addr.c \
- tests/check-attr.c
+ tests/check-attr.c \
+ tests/check-ematch-tree-clone.c
tests_check_all_CPPFLAGS = \
$(tests_cppflags) \