summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-02-26 19:47:10 +0100
committerThomas Haller <thaller@redhat.com>2017-02-26 19:47:10 +0100
commit5013d19657fdad8da757322338dbcf7c3b536da3 (patch)
tree4aee1fbd58e79e9c43dd9657fa75349da2a0a1ee /Makefile.am
parent3e18948f17148e6a3c4255bdeaaf01ef6081ceeb (diff)
downloadlibnl-5013d19657fdad8da757322338dbcf7c3b536da3.tar.gz
build: cleanup top-level Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 20 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 61237dc9..dddfb663 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,23 +2,33 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = include lib man python tests
-
-pkgconfig_DATA = libnl-3.0.pc \
- libnl-route-3.0.pc \
- libnl-genl-3.0.pc \
- libnl-nf-3.0.pc \
- libnl-xfrm-3.0.pc \
- libnl-idiag-3.0.pc
+SUBDIRS = \
+ include \
+ lib \
+ man \
+ python \
+ tests
if ENABLE_CLI
SUBDIRS += src
-pkgconfig_DATA += libnl-cli-3.0.pc
endif
+pkgconfig_DATA = \
+ libnl-3.0.pc \
+ libnl-route-3.0.pc \
+ libnl-genl-3.0.pc \
+ libnl-nf-3.0.pc \
+ libnl-xfrm-3.0.pc \
+ libnl-idiag-3.0.pc
+
+if ENABLE_CLI
+pkgconfig_DATA += libnl-cli-3.0.pc
+endif
pkgsysconfdir = ${sysconfdir}/libnl
-pkgsysconf_DATA = etc/pktloc etc/classid
+pkgsysconf_DATA = \
+ etc/pktloc \
+ etc/classid
EXTRA_DIST = \
$(pkgsysconf_DATA) \