summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-02-27 12:13:13 +0100
committerThomas Haller <thaller@redhat.com>2017-02-27 13:36:03 +0100
commit812e16a77f66acf6b3f8cac2b8334f3b7a754280 (patch)
tree60dc8e1bcc0b95d49ce0d3d2c3cfc3d77a798e0f /Makefile.am
parent3cb28534d34392ceec4adead0cfa97039796ccb7 (diff)
downloadlibnl-812e16a77f66acf6b3f8cac2b8334f3b7a754280.tar.gz
build: move compiler warning flags to separate autoconf variable
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 81da1fc6..76d51e18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,9 @@ pkgconfig_DATA = \
libnl-xfrm-3.0.pc \
libnl-idiag-3.0.pc
+warn_cppflags = \
+ -Wall
+
###############################################################################
libnlincludedir = $(includedir)/libnl@MAJ_VERSION@
@@ -283,7 +286,7 @@ EXTRA_DIST += \
###############################################################################
lib_cppflags = \
- -Wall \
+ $(warn_cppflags) \
-Wmissing-prototypes \
-D_GNU_SOURCE \
-DSYSCONFDIR=\"$(sysconfdir)/libnl\" \
@@ -564,7 +567,7 @@ src_lib_libnl_cli_3_la_SOURCES = \
EXTRA_src_lib_libnl_cli_3_la_DEPENDENCIES = \
libnl-cli-3.sym
src_lib_libnl_cli_3_la_CPPFLAGS = \
- -Wall \
+ $(warn_cppflags) \
-D_GNU_SOURCE \
-DPKGLIBDIR=\"$(pkglibdir)\" \
-DSYSCONFDIR=\"$(sysconfdir)\" \
@@ -584,7 +587,7 @@ src_lib_libnl_cli_3_la_LIBADD = \
###############################################################################
src_cppflags = \
- -Wall \
+ $(warn_cppflags) \
-D_GNU_SOURCE \
-DSYSCONFDIR=\"$(sysconfdir)/libnl\" \
-I$(srcdir)/include/linux-private \
@@ -757,7 +760,7 @@ src_nl_util_addr_LDADD = $(src_ldadd)
###############################################################################
tests_cppflags = \
- -Wall \
+ $(warn_cppflags) \
-D_GNU_SOURCE \
-DSYSCONFDIR=\"$(sysconfdir)/libnl\" \
-I$(srcdir)/include/linux-private \