summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-02-26 21:05:37 +0100
committerThomas Haller <thaller@redhat.com>2017-02-27 13:20:34 +0100
commitc1567ea637ef51868b0f31a185caa6c3e740d0fd (patch)
tree4dfe0994a1c0253b597bac4cbef886e6beae9ee5 /Makefile.am
parentbee04e40f392186c6b5374dbdcb672c08aea19c9 (diff)
downloadlibnl-c1567ea637ef51868b0f31a185caa6c3e740d0fd.tar.gz
build: merge python/Makefile.am into top-level makefile
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 39 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8dd245d5..8e7e621d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,6 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = \
. \
- python \
tests
if ENABLE_CLI
@@ -538,6 +537,45 @@ dist_man8_MANS = \
###############################################################################
+EXTRA_DIST += \
+ python/README \
+ \
+ python/doc/conf.py \
+ python/doc/core.rst \
+ python/doc/index.rst \
+ python/doc/route_addr.rst \
+ python/doc/route.rst \
+ \
+ python/examples/iface.py \
+ python/examples/nl80211.py \
+ python/examples/wiphy.py \
+ \
+ python/netlink/capi.i \
+ python/netlink/fixes.h \
+ python/netlink/__init__.py \
+ python/netlink/core.py \
+ python/netlink/util.py \
+ python/netlink/utils.h \
+ \
+ python/netlink/genl/capi.i \
+ python/netlink/genl/__init__.py \
+ \
+ python/netlink/route/capi.i \
+ python/netlink/route/__init__.py \
+ python/netlink/route/address.py \
+ python/netlink/route/link.py \
+ python/netlink/route/tc.py \
+ python/netlink/route/links/__init__.py \
+ python/netlink/route/links/dummy.py \
+ python/netlink/route/links/inet.py \
+ python/netlink/route/links/vlan.py \
+ python/netlink/route/qdisc/__init__.py \
+ python/netlink/route/qdisc/htb.py \
+ \
+ python/tests/test-create-bridge.py
+
+###############################################################################
+
if ENABLE_CLI
pkgconfig_DATA += libnl-cli-3.0.pc
endif