summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Forney <mforney@mforney.org>2019-08-11 04:49:07 +0000
committerThomas Haller <thaller@redhat.com>2019-08-16 07:42:03 +0200
commitde72910e6b3ec4503f23538682a89c4d444c7a92 (patch)
treeadb4ac751ff7e9d2cbf3a17d9c2191fb0d80e56f /Makefile.am
parent1a88619b72c77b5390076ad703bfa3de4fa0348d (diff)
downloadlibnl-de72910e6b3ec4503f23538682a89c4d444c7a92.tar.gz
all: Avoid pointer arithmetic on `void *`
ISO C requires that the pointer operand to the binary + operator be to a complete object type[0]. [0] http://port70.net/~nsz/c/c11/n1570.html#6.5.6p2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c01e988..a698e73d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,7 @@ warn_cppflags = \
-Wno-unused-parameter \
-Wno-sign-compare \
-Wno-missing-field-initializers \
+ -Wpointer-arith \
$(NULL)
###############################################################################