summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJiří Župka <jzupka@redhat.com>2011-10-04 16:06:22 +0200
committerThomas Graf <tgraf@redhat.com>2011-10-10 11:39:24 +0200
commitf90dc636cbe69ce157b395d0ae8c06b82ac965e5 (patch)
treef475f20808f6fb9b8bc5eef775cd252c10e765fe /Makefile.am
parentd3bb7c9cf16587c71fc01311fe6d8ae5a0280246 (diff)
downloadlibnl-f90dc636cbe69ce157b395d0ae8c06b82ac965e5.tar.gz
Add libnl-cli-3.0 to pkg-config tool
Signed-off-by: Jiří Župka <jzupka@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 70d1b761..4b8f020e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,9 +3,11 @@
ACLOCAL_AMFLAGS = -I m4
OPT_DIRS =
+PKGCONFIGS =
if ENABLE_CLI
OPT_DIRS += src
+PKGCONFIGS += libnl-cli-3.0.pc
endif
SUBDIRS = include lib doc man python $(OPT_DIRS)
@@ -13,7 +15,9 @@ SUBDIRS = include lib doc man python $(OPT_DIRS)
pkgconfig_DATA = libnl-3.0.pc \
libnl-route-3.0.pc \
libnl-genl-3.0.pc \
- libnl-nf-3.0.pc
+ libnl-nf-3.0.pc \
+ $(PKGCONFIGS)
+
pkgsysconfdir = ${sysconfdir}/libnl
pkgsysconf_DATA = etc/pktloc etc/classid