summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRubens Figueiredo <rubens.figueiredo@bisdn.de>2020-07-20 10:44:39 +0200
committerThomas Haller <thaller@redhat.com>2022-03-14 08:49:11 +0100
commit0ec6c6c2f0238f12c9088d454a83433cfdf9792c (patch)
tree85e970f3f405824629c5f0e43236960a39d46ddb /Makefile.am
parentc980034d9fc3e23b9ef7c5431307c3ad574841b0 (diff)
downloadlibnl-0ec6c6c2f0238f12c9088d454a83433cfdf9792c.tar.gz
mdb: support bridge multicast database notification
The Linux kernel has a notification system via Netlink that reports the changes in the multicast database over the RTNLGRP_MDB multicast socket. As such notifications such as RTM_NEWMDB, RTM_GETMDB can be processed in userspace. libnl must support the capability of processing these messages, e.g. RTM_GETMDB. This commit adds a new rtnl_mdb object as well as a route/mdb cache, in order to expose the contents of the multicast database.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8372e356..04780871 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,6 +105,7 @@ libnlinclude_netlink_route_HEADERS = \
include/netlink/route/class.h \
include/netlink/route/classifier.h \
include/netlink/route/link.h \
+ include/netlink/route/mdb.h \
include/netlink/route/neighbour.h \
include/netlink/route/neightbl.h \
include/netlink/route/netconf.h \
@@ -212,6 +213,7 @@ libnlinclude_netlink_cli_HEADERS = \
include/netlink/cli/rule.h \
include/netlink/cli/tc.h \
include/netlink/cli/utils.h \
+ include/netlink/cli/mdb.h \
$(NULL)
endif
@@ -426,6 +428,7 @@ lib_libnl_route_3_la_SOURCES = \
lib/route/neightbl.c \
lib/route/netconf.c \
lib/route/nexthop.c \
+ lib/route/mdb.c \
lib/route/nexthop_encap.c \
lib/route/nh_encap_mpls.c \
lib/route/pktloc.c \