summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2023-07-28 17:21:19 +0200
committerThomas Haller <thaller@redhat.com>2023-07-31 15:18:08 +0200
commitf6c26127f2dee628490e9b8fa155380e70b1b638 (patch)
tree71d2d999a7db8cc7421cac7d37ea9f2f47bd2a34 /Makefile.am
parent2da8481b505509aab05bb37f8fc54536a3f5e99f (diff)
downloadlibnl-f6c26127f2dee628490e9b8fa155380e70b1b638.tar.gz
nl-aux: add "include/nl-aux-{core,route}" headers
We have "include/netlink-private/netlink.h", which is private API used internally. However, it's confusing where "include/netlink-private/netlink.h" can be used. For example, it contains some "libnl-route-3.so" specific extensions like "link_lookup()", hence you would think that it can only be used with libraries that also use "libnl-route-3.so". Well, since it's a header, you actually can also use it for example under "lib/xfrm/", you couldn't just use those declarations because they are implemented and accessible only under "lib/route/" In a first step to clean this up, and move helper to separate headers, add "include/nl-aux-{core,route}" headers with certain clear usage. Clear in the sense who may use those headers, and what the implementation of those headers may use.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3bea0b94..030bb4b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -274,7 +274,6 @@ noinst_HEADERS = \
include/netlink-private/cache-api.h \
include/netlink-private/genl.h \
include/netlink-private/netlink.h \
- include/netlink-private/nl-auto.h \
include/netlink-private/object-api.h \
include/netlink-private/route/link/api.h \
include/netlink-private/route/link/sriov.h \
@@ -285,6 +284,8 @@ noinst_HEADERS = \
include/netlink-private/socket.h \
include/netlink-private/tc.h \
include/netlink-private/types.h \
+ include/nl-aux-core/nl-core.h \
+ include/nl-aux-route/nl-route.h \
$(NULL)
###############################################################################