summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-05-12 12:47:19 +0200
committerThomas Haller <thaller@redhat.com>2017-05-12 12:57:34 +0200
commitc881a27fbda7233405d91d70ec517386e2d85304 (patch)
treec27889c980c773b261e01378606752e27d549a96 /configure.ac
parent144c6c5e6a31cbcfad9e55256a2b1e20b238b24a (diff)
downloadlibnl-c881a27fbda7233405d91d70ec517386e2d85304.tar.gz
build: allow building cli without dynamic librarires support
Commit 3cb28534d34392ceec4adead0cfa97039796ccb7 enables building of cli always as part of `make check`. As cli previously always included <dlfcn.h>, this broke tests for building with toolchains that don't support dynamic library loading. Add a configure check and disable dlopen() based on whether <dlfcn.h> is available. Signed-off-by: Thomas Haller <thaller@redhat.com> https://github.com/thom311/libnl/pull/141
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7402fdf..387a53b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,8 @@ AM_CONDITIONAL([ENABLE_CLI], [test "$enable_cli" != "no"])
AM_CONDITIONAL([ENABLE_CLI_INSTALL_BIN], [test "$enable_cli" = "bin"])
AM_CONDITIONAL([ENABLE_CLI_INSTALL_SBIN], [test "$enable_cli" = "sbin"])
+AC_CHECK_HEADERS(dlfcn.h, [], [])
+
AC_ARG_ENABLE([pthreads],
AS_HELP_STRING([--disable-pthreads], [Disable pthreads support]),
[enable_pthreads="$enableval"], [enable_pthreads="yes"])