aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 28 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f9371a60..d8483ab4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2889,7 +2889,34 @@ if test "x$enable_rdma" != "xno"; then
CFLAGS="$LIBIBVERBS_CFLAGS"
LIBS="$LIBIBVERBS_LIBS"
AC_CHECK_HEADER(infiniband/verbs.h, [
- AC_MSG_WARN([Testing 1 2 3...])
+ #
+ # ibv_create_flow may be defined as a static inline
+ # function in infiniband/verbs.h, so we can't
+ # use AC_CHECK_LIB.
+ #
+ # Too bad autoconf has no AC_SYMBOL_EXISTS()
+ # macro that works like CMake's check_symbol_exists()
+ # function, to check do a compile check like
+ # this (they do a clever trick to avoid having
+ # to know the function's signature).
+ #
+ AC_MSG_CHECKING(whether libibverbs defines ibv_create_flow)
+ AC_TRY_LINK(
+ [
+ #include <infiniband/verbs.h>
+ ],
+ [
+ (void) ibv_create_flow((struct ibv_qp *) NULL,
+ (struct ibv_flow_attr *) NULL);
+ ],
+ [
+ AC_MSG_RESULT([yes])
+ found_usable_libibverbs=yes
+ ],
+ [
+ AC_MSG_RESULT([no])
+ ]
+ )
])
CFLAGS="$save_CFLAGS"
LIBS="$save_LIBS"