aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2024-03-22 18:31:46 +0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2024-03-22 18:31:46 +0000
commit945297e8e4ba57bd463a654c83b3e2aef04c9c2a (patch)
treeee1f53361d29c32f760a8aeed29bf7a966ea89cf /Makefile.am
parent5d19b1bb0f5694f2ae47b3cc2ccfeb571764b439 (diff)
parent7f2442bc0587522c6a8de11372ff60b64bb06e28 (diff)
downloadlibpng-945297e8e4ba57bd463a654c83b3e2aef04c9c2a.tar.gz
Merge "Snap for 11612745 from 6cc454b6e9367825dfc9d3f230a6bb5337b1cb3b to emu-35-1-release" into emu-35-1-releaseemu-35-1-release
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 08db3e599..f21107e65 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am, the source file for Makefile.in (and hence Makefile), is
#
+# Copyright (c) 2018 Cosmin Truta
# Copyright (c) 2004-2016 Glenn Randers-Pehrson
-# Last changed in libpng 1.6.25 [September 1, 2016]
#
# This code is released under the libpng license.
# For conditions of distribution and use, see the disclaimer
@@ -59,8 +59,7 @@ pngcp_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
# Generally these are single line shell scripts to run a test with a particular
# set of parameters:
TESTS =\
- tests/pngtest\
- tests/pngtest-badpngs\
+ tests/pngtest-all\
tests/pngvalid-gamma-16-to-8 tests/pngvalid-gamma-alpha-mode\
tests/pngvalid-gamma-background tests/pngvalid-gamma-expand16-alpha-mode\
tests/pngvalid-gamma-expand16-background\
@@ -95,7 +94,8 @@ libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@_la_SOURCES = png.c pngerror.c\
if PNG_ARM_NEON
libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@_la_SOURCES += arm/arm_init.c\
- arm/filter_neon.S arm/filter_neon_intrinsics.c
+ arm/filter_neon.S arm/filter_neon_intrinsics.c \
+ arm/palette_neon_intrinsics.c
endif
if PNG_MIPS_MSA
@@ -147,7 +147,7 @@ pkgconfig_DATA = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.pc
# from those directories being included. This only works if the configure is
# not done in the source directory!
EXTRA_DIST= \
- ANNOUNCE CHANGES INSTALL LICENSE README TODO \
+ ANNOUNCE AUTHORS CHANGES INSTALL LICENSE README TODO TRADEMARK \
pngtest.png pngbar.png pngnow.png pngbar.jpg autogen.sh \
${srcdir}/contrib ${srcdir}/projects ${srcdir}/scripts \
$(TESTS) $(XFAIL_TESTS) tests/pngstest \