aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Buka <vitalybuka@google.com>2017-06-09 16:30:49 -0700
committerVitaly Buka <vitalybuka@gmail.com>2017-06-09 18:02:29 -0700
commit418eba677a25206ef8b6679fcf0c8275e7771095 (patch)
tree75c9ee93f7561f1bcba19825e660371065660ae7 /src/CMakeLists.txt
parent24d9fd000704070c0eb0747d3a0e594a63bf8e53 (diff)
downloadlibprotobuf-mutator-418eba677a25206ef8b6679fcf0c8275e7771095.tar.gz
Add function to fix UTF-8 strings.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5486f23..8fcfdb8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -15,9 +15,10 @@
add_subdirectory(libfuzzer)
add_library(protobuf-mutator
+ binary_format.cc
mutator.cc
text_format.cc
- binary_format.cc)
+ utf8_fix.cc)
target_link_libraries(protobuf-mutator
${PROTOBUF_LIBRARY})
set_property(TARGET protobuf-mutator
@@ -29,6 +30,7 @@ protobuf_generate_cpp(PROTO_SRCS PROTO_HDRS
add_executable(mutator_test
mutator_test.cc
+ utf8_fix_test.cc
weighted_reservoir_sampler_test.cc
${PROTO_SRCS})
target_link_libraries(mutator_test