aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57601a5..08bfedd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,15 +35,6 @@ include(ExternalProject)
set(THREADS_PREFER_PTHREAD_FLAG ON)
find_package(Threads REQUIRED)
-# Check the target architecture and set compiler flags accordingly
-if(CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64")
- # 64-bit architecture
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -m64")
-else()
- # 32-bit architecture
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -m32")
-endif()
-
set(SRC_DIR "${CMAKE_CURRENT_SOURCE_DIR}")
include("${SRC_DIR}/utils.cmake")