aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKonstantin Belousov <kostik@pooma.home>2010-03-07 12:46:05 +0200
committerKonstantin Belousov <kostik@pooma.home>2010-03-07 12:46:05 +0200
commit59d38aaccd53c13d962f07dbcb44b3ec5513c5ca (patch)
tree0fb931bf54a81910e3b4eda422c225f95a0b62c8 /configure.in
parentd7eea914485d5d5d3c7b29a74a68541240b6a090 (diff)
downloadlibunwind-59d38aaccd53c13d962f07dbcb44b3ec5513c5ca.tar.gz
Properly handle -ldl and -lutil
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 74439433..7272a651 100644
--- a/configure.in
+++ b/configure.in
@@ -23,6 +23,15 @@ AM_PROG_CC_C_O
dnl Checks for libraries.
AC_CHECK_LIB(uca, __uc_get_grs)
+AC_CHECK_LIB(util, kinfo_getvmmap)
+OLD_LIBS=${LIBS}
+AC_SEARCH_LIBS(dl, dlopen)
+LIBS=${OLD_LIBS}
+case "$ac_cv_search_dlopen" in
+ -l*) DLLIB=$ac_cv_search_dlopen;;
+ *) DLLIB="";;
+esac
+
CHECK_ATOMIC_OPS
dnl Checks for header files.
@@ -241,6 +250,7 @@ AC_SUBST(PKG_MINOR)
AC_SUBST(PKG_EXTRA)
AC_SUBST(PKG_MAINTAINER)
AC_SUBST(enable_cxx_exceptions)
+AC_SUBST(DLLIB)
AC_CONFIG_FILES(Makefile src/Makefile tests/Makefile tests/check-namespace.sh
doc/Makefile doc/common.tex include/libunwind-common.h)