aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJose Flavio Aguilar Paulino <jflavio@br.ibm.com>2007-08-06 20:23:42 -0600
committerDavid Mosberger-Tang <davidm@koala.mostang.com>2007-08-06 20:23:42 -0600
commita1e7ee48365a76804361e891c4b4d1f13c78c20a (patch)
tree4f48258617e19821a7fbb1530da4a408dd2b4bd0 /configure.in
parent5c95d139dfa3de77e38877965192430600602f3d (diff)
downloadlibunwind-a1e7ee48365a76804361e891c4b4d1f13c78c20a.tar.gz
Just a small patch to build system, it helps if you build in a power
without altivec.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4619d506..775a6f81 100644
--- a/configure.in
+++ b/configure.in
@@ -63,6 +63,16 @@ is_gcc_m64() {
fi;
}
+is_gcc_altivec() {
+ if test `echo $CFLAGS | grep "\-maltivec" -c` -eq 1 ; then echo has_altivec;
+ else
+ if test `echo $CC | grep "\-maltivec" -c` -eq 1 ; then echo has_altivec; else echo no_altivec; fi;
+ fi;
+}
+
+use_altivec=`is_gcc_altivec`
+AM_CONDITIONAL(USE_ALTIVEC, test x$use_altivec = xhas_altivec)
+
get_arch() {
case "$1" in
i?86) echo x86;;