aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKonstantin Belousov <kostik@pooma.home>2010-03-06 15:04:56 +0200
committerKonstantin Belousov <kostik@pooma.home>2010-03-06 15:04:56 +0200
commitcf6ae3548f96fa90da32b96529897cb6257355c1 (patch)
tree669bf35201330ec434a9b8371beada5b0abc72a0 /configure.in
parentd11456ffbf6dd6f556eb3bc64e8a368e7e3381c5 (diff)
downloadlibunwind-cf6ae3548f96fa90da32b96529897cb6257355c1.tar.gz
Code to read/write user memory on FreeBSD
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cbf581ce..e5d4ac28 100644
--- a/configure.in
+++ b/configure.in
@@ -59,6 +59,20 @@ AC_CHECK_DECLS(PTRACE_POKEUSER, [], [],
#endif
#include <sys/ptrace.h>
])
+AC_CHECK_DECLS(PTRACE_POKEDATA, [], [],
+[$ac_includes_default
+#if HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#include <sys/ptrace.h>
+])
+AC_CHECK_DECLS(PT_IO, [], [],
+[$ac_includes_default
+#if HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#include <sys/ptrace.h>
+])
AC_CHECK_DECLS(PT_GETFPREGS, [], [],
[$ac_includes_default
#if HAVE_SYS_TYPES_H