aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormostang.com!davidm <mostang.com!davidm>2003-04-03 07:59:15 +0000
committermostang.com!davidm <mostang.com!davidm>2003-04-03 07:59:15 +0000
commitebfaebdee9ff0743a6c41102cd6dc2063c3387c7 (patch)
tree55453adc24270883dd7f6a6e078388c61975122d /configure.in
parentb513773cb2422dbf69979d5d29474c7a18c60654 (diff)
downloadlibunwind-ebfaebdee9ff0743a6c41102cd6dc2063c3387c7.tar.gz
Add check for -luca (needed on HP-UX).
Add check for <sys/uc_access.h> (needed on HP-UX). (OS_HPUX): New conditional. (Logical change 1.75)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ae0d644a..89d481d9 100644
--- a/configure.in
+++ b/configure.in
@@ -15,11 +15,12 @@ AM_PROG_LIBTOOL
AM_PROG_AS
dnl Checks for libraries.
+AC_CHECK_LIB(uca, __uc_get_grs)
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(asm/ptrace_offsets.h endian.h execinfo.h ia64intrin.h \
- unistd.h)
+ sys/uc_access.h unistd.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -50,6 +51,7 @@ AM_CONDITIONAL(ARCH_IA64, test x$target_arch = xia64)
AM_CONDITIONAL(ARCH_HPPA, test x$target_arch = xhppa)
AM_CONDITIONAL(ARCH_X86, test x$target_arch = xx86)
AM_CONDITIONAL(OS_LINUX, expr x$target_os : xlinux >/dev/null)
+AM_CONDITIONAL(OS_HPUX, expr x$target_os : xhpux >/dev/null)
if test x$target_arch != x$build_arch; then
CPPFLAGS="${CPPFLAGS} -DUNW_REMOTE_ONLY"