aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLassi Tuura <lat@iki.fi>2011-03-19 10:00:48 +0100
committerArun Sharma <asharma@fb.com>2011-03-24 22:33:17 -0700
commit9e98f15e9aee12e67cd5956d06ccb559f6a06213 (patch)
tree5131aa7120043dab6da38f6765514858d31f9b23 /src/Makefile.am
parent6c1a58fd06eea3a45c6de38eb5d1f79f636bb8d5 (diff)
downloadlibunwind-9e98f15e9aee12e67cd5956d06ccb559f6a06213.tar.gz
Fast back-trace for x86_64 for only collecting the call stack.
Adds new function to perform a pure stack walk without unwinding, functionally similar to backtrace() but accelerated by an address attribute cache the caller maintains across calls.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 68470eab..9703724e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -258,8 +258,8 @@ libunwind_la_SOURCES_x86_64 = $(libunwind_la_SOURCES_x86_64_common) \
x86_64/setcontext.S \
x86_64/Lcreate_addr_space.c x86_64/Lget_save_loc.c x86_64/Lglobal.c \
x86_64/Linit.c x86_64/Linit_local.c x86_64/Linit_remote.c \
- x86_64/Lget_proc_info.c x86_64/Lregs.c \
- x86_64/Lresume.c x86_64/Lstep.c x86_64/getcontext.S
+ x86_64/Lget_proc_info.c x86_64/Lregs.c x86_64/Lresume.c \
+ x86_64/Lstash_frame.c x86_64/Lstep.c x86_64/Ltrace.c x86_64/getcontext.S
# The list of files that go into libunwind-x86_64:
libunwind_x86_64_la_SOURCES_x86_64 = $(libunwind_la_SOURCES_x86_64_common) \
@@ -267,8 +267,8 @@ libunwind_x86_64_la_SOURCES_x86_64 = $(libunwind_la_SOURCES_x86_64_common) \
$(libunwind_la_SOURCES_generic) \
x86_64/Gcreate_addr_space.c x86_64/Gget_save_loc.c x86_64/Gglobal.c \
x86_64/Ginit.c x86_64/Ginit_local.c x86_64/Ginit_remote.c \
- x86_64/Gget_proc_info.c x86_64/Gregs.c \
- x86_64/Gresume.c x86_64/Gstep.c
+ x86_64/Gget_proc_info.c x86_64/Gregs.c x86_64/Gresume.c \
+ x86_64/Gstash_frame.c x86_64/Gstep.c x86_64/Gtrace.c
# The list of local files that go to Power 64 and 32:
libunwind_la_SOURCES_ppc = ppc/Lcreate_addr_space.c \