aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYavor Goulishev <yavor@google.com>2011-05-23 11:58:06 -0700
committerYavor Goulishev <yavor@google.com>2011-05-23 11:58:06 -0700
commite9a683104ef3f40d38459c0ca62a2d46f20b0714 (patch)
tree1ef8522d89d3e24c69ed6253e657211a0faa6564 /Makefile.am
parent88d2245b9a11a11134b39d9d0e54b5c2dba8aeef (diff)
downloadlibusb-compat-e9a683104ef3f40d38459c0ca62a2d46f20b0714.tar.gz
Moving the libusb-compat source from jumper to external.android-sdk-tools_r12android-sdk-adt_r12
Change-Id: Icd5631b38c4b1a16ae0f715d32c1e1d4ba82c435
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..c12a0fe
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,24 @@
+AUTOMAKE_OPTIONS = dist-bzip2
+ACLOCAL_AMFLAGS = -I m4
+DISTCLEANFILES = ChangeLog libusb.pc
+EXTRA_DIST = LICENSE
+SUBDIRS = libusb
+
+if BUILD_EXAMPLES
+SUBDIRS += examples
+endif
+
+pkgconfigdir=$(libdir)/pkgconfig
+pkgconfig_DATA=libusb.pc
+
+bin_SCRIPTS = libusb-config
+
+.PHONY: ChangeLog dist-up
+ChangeLog:
+ git --git-dir $(top_srcdir)/.git log > ChangeLog || touch ChangeLog
+
+dist-hook: ChangeLog
+
+dist-up: dist
+ rsync $(distdir).tar.bz2 frs.sourceforge.net:uploads/
+