aboutsummaryrefslogtreecommitdiff
path: root/libusb/Makefile.am
diff options
context:
space:
mode:
authorYavor Goulishev <yavor@google.com>2011-05-23 11:58:06 -0700
committerYavor Goulishev <yavor@google.com>2011-05-23 11:58:06 -0700
commite9a683104ef3f40d38459c0ca62a2d46f20b0714 (patch)
tree1ef8522d89d3e24c69ed6253e657211a0faa6564 /libusb/Makefile.am
parent88d2245b9a11a11134b39d9d0e54b5c2dba8aeef (diff)
downloadlibusb-compat-e9a683104ef3f40d38459c0ca62a2d46f20b0714.tar.gz
Moving the libusb-compat source from jumper to external.android-sdk-tools_r12android-sdk-adt_r12
Change-Id: Icd5631b38c4b1a16ae0f715d32c1e1d4ba82c435
Diffstat (limited to 'libusb/Makefile.am')
-rw-r--r--libusb/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/libusb/Makefile.am b/libusb/Makefile.am
new file mode 100644
index 0000000..33a609a
--- /dev/null
+++ b/libusb/Makefile.am
@@ -0,0 +1,9 @@
+include_HEADERS = usb.h
+lib_LTLIBRARIES = libusb.la
+
+libusb_la_SOURCES = core.c usbi.h
+libusb_la_CFLAGS = -fvisibility=hidden $(AM_CFLAGS) $(LIBUSB_1_0_CFLAGS)
+libusb_la_LIBADD = $(LIBUSB_1_0_LIBS)
+libusb_la_LDFLAGS = -version-info $(LT_MAJOR):$(LT_REVISION):$(LT_AGE) \
+ -release 0.1
+