aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Green <andy@warmcat.com>2020-06-10 19:17:08 +0100
committerAndy Green <andy@warmcat.com>2020-06-10 19:17:08 +0100
commit15ce46d9716dfeb70ff4f6d25225bf78f1443a5b (patch)
tree6a687d780f8c39aad2724b30fb81d74ad8acbf18 /CMakeLists.txt
parentad5a4f7040615c33fc5ab0903bf66ec0376510b9 (diff)
downloadlibwebsockets-15ce46d9716dfeb70ff4f6d25225bf78f1443a5b.tar.gz
drivers: initial generic gpio and i2c plus bitbang
Make a start on generic peripheral and bus drivers to provide meta-functionality regardless of platform. On the one hand this simply provides... - bitbang i2c on top of esp-idf gpio apis - ssd1306 oled chip driver as found on Heltec WB32 - modifications to the minimal example test for esp32 to use that ... on the other hand, those capabilities are provided by creating: - an abstract i2c class object - an abstract gpio class object - i2c class implementation using the abstract gpio for bitbang - an abstract display class object - an abstract display state (brightness, animated change, on/off/init tracking, autodim after inactive, auto-off / blanking after inactive) ... with the intention, eg, you only have to add a platform implementation for the gpio to be able to use the i2c-based display drivers and state handling, and i2c bitbang, without any other modifications.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ad8250a..2c040559 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,6 +153,12 @@ option(LWS_WITH_LIBEVENT "Compile with support for libevent" OFF)
option(LWS_WITH_GLIB "Compile with support for glib event loop" OFF)
#
+# LWS Drivers
+#
+
+option(LWS_WITH_DRIVERS "With generic drivers for gpio, i2c, display etc" OFF)
+
+#
# Static / Dynamic build options
#
option(LWS_WITH_STATIC "Build the static version of the library" ON)