aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Green <andy@warmcat.com>2020-06-03 09:29:28 +0100
committerAndy Green <andy@warmcat.com>2020-06-03 09:36:20 +0100
commit16cbbe2b40134cc7dd6ee16c4f356c150e3fb52d (patch)
treef990182354ef499869593d1b618b0d21e2ba8dbe /CMakeLists.txt
parentc0294c3e10c2867a72c233604c790380b276761d (diff)
downloadlibwebsockets-16cbbe2b40134cc7dd6ee16c4f356c150e3fb52d.tar.gz
mingw: update cross toolchain and add 32 and 64 default builds to sai
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3bb87145..df913b45 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -525,6 +525,16 @@ CHECK_INCLUDE_FILE(malloc.h LWS_HAVE_MALLOC_H)
CHECK_INCLUDE_FILE(pthread.h LWS_HAVE_PTHREAD_H)
CHECK_INCLUDE_FILE(inttypes.h LWS_HAVE_INTTYPES_H)
+if (WIN32 OR MSVC)
+ CHECK_C_SOURCE_COMPILES("#include <winsock2.h>
+ #include <afunix.h>
+ int main() { return 0; }" LWS_HAVE_WIN32_AFUNIX_H)
+
+ if (LWS_UNIX_SOCK AND NOT LWS_HAVE_WIN32_AFUNIX_H)
+ message(FATAL_ERROR "No afunix.h in toolchain for LWS_UNIX_SOCK")
+ endif()
+endif()
+
CHECK_LIBRARY_EXISTS(cap cap_set_flag "" LWS_HAVE_LIBCAP)