aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLaszlo Boszormenyi (GCS) <gcs@debian.org>2020-07-19 16:29:07 +0200
committerAndy Green <andy@warmcat.com>2020-07-20 06:27:24 +0100
commit355be53fa6c74021fc6e3ee3683836a6a666223e (patch)
tree41db3956ce6b1b3ea26deff9534dd29884d4ce39 /CMakeLists.txt
parentdba03e40371edbcf5b31a00321dc7a906db94209 (diff)
downloadlibwebsockets-355be53fa6c74021fc6e3ee3683836a6a666223e.tar.gz
cmake: Link with cap if it's found and used
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a97b796..06fc6fbc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -799,6 +799,11 @@ if (LWS_WITH_HUBBUB)
list(APPEND LIB_LIST ${LIBHUBBUB_LIBRARIES} )
endif()
+if (LWS_HAVE_LIBCAP)
+ find_library(LIBCAP_LIBRARIES NAMES cap)
+ list(APPEND LIB_LIST ${LIBCAP_LIBRARIES} )
+endif()
+
#
# Append the "at end" pieces to the lib list