aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Green <andy@warmcat.com>2020-04-14 19:04:13 +0100
committerAndy Green <andy@warmcat.com>2020-05-11 15:40:13 +0100
commit9f1d019352e5d06db436674b985da4eff9738777 (patch)
tree58730d61b5fd25a953ec5a6b7261e1ad774865ab /CMakeLists.txt
parentaf26f0c76547cc652ec287be8537a0eac3578d54 (diff)
downloadlibwebsockets-9f1d019352e5d06db436674b985da4eff9738777.tar.gz
CTest: migrate and deprecate existing selftest scripts
Replace the bash selftest plumbing with CTest. To use the selftests, build with -DLWS_WITH_MINIMAL_EXAMPLES=1 and `CTEST_OUTPUT_ON_FAILURE=1 make test` or just `make test`. To disable tests that require internet access, also give -DLWS_CTEST_INTERNET_AVAILABLE=0 Remove travis and appveyor scripts on master. Remove travis and appveyor decals on README.md.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72bbe67f..5d5abe38 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -272,7 +272,8 @@ if(LWS_WITH_DISTRO_RECOMMENDED)
set(LWS_WITH_STRUCT_JSON 1)
set(LWS_WITH_STRUCT_SQLITE3 1)
set(LWS_WITH_SPAWN 1)
- set(LWS_WITH_FSMOUNT 1)
+# libmount is problematic on Centos 8 / RHEL 8
+# set(LWS_WITH_FSMOUNT 1)
set(LWS_ROLE_MQTT 1)
set(LWS_WITH_SECURE_STREAMS 1)
set(LWS_WITH_SECURE_STREAMS_PROXY_API 1)