aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Green <andy@warmcat.com>2021-03-08 10:52:06 +0000
committerAndy Green <andy@warmcat.com>2021-03-08 20:43:58 +0000
commitc00ece34a1601c745b705af64df33eb8dc2449ff (patch)
tree43eb75b7186497958d3f3dc0469c029b46cbb2ad /CMakeLists.txt
parentd72955cc7ff24182f025fe868354208cb9a9942d (diff)
downloadlibwebsockets-c00ece34a1601c745b705af64df33eb8dc2449ff.tar.gz
solaris: openssl: defeat openssl deprecation of md5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e39373bf..9be767fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -287,6 +287,11 @@ else()
set(LWS_WITH_NETLINK 0)
endif()
+if (${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
+ # its openssl has md5 deprecated
+ set(LWS_SUPPRESS_DEPRECATED_API_WARNINGS 1)
+endif()
+
#
# to use miniz, enable both LWS_WITH_ZLIB and LWS_WITH_MINIZ