aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCatalin <cra@mega.nz>2021-03-25 08:37:36 +0000
committerAndy Green <andy@warmcat.com>2021-04-04 05:34:11 +0100
commitd5753b6298cf54dcd167f8e23458a356d7e268a7 (patch)
tree59d4803550bb67ec981f4990622635fb065dac1b /CMakeLists.txt
parente4d381eadd0d7c5050228d3c53bfddaf3544851b (diff)
downloadlibwebsockets-d5753b6298cf54dcd167f8e23458a356d7e268a7.tar.gz
tls: openssl-only: client-only: session caching
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5267f644..56ca5226 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,7 +163,7 @@ option(LWS_WITH_WOLFSSL "Use wolfSSL replacement for OpenSSL. When setting this,
option(LWS_SSL_CLIENT_USE_OS_CA_CERTS "SSL support should make use of the OS-installed CA root certs" ON)
option(LWS_TLS_LOG_PLAINTEXT_RX "For debugging log the received plaintext as soon as decrypted" OFF)
option(LWS_TLS_LOG_PLAINTEXT_TX "For debugging log the transmitted plaintext just before encryption" OFF)
-
+option(LWS_WITH_TLS_SESSIONS "Enable persistent, resumable TLS sessions" ON)
#
# Event library options (may select multiple, or none for default poll()