aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Green <andy@warmcat.com>2020-03-19 14:36:05 +0000
committerAndy Green <andy@warmcat.com>2020-03-19 14:36:05 +0000
commit1acf0b33c7386f4c5366e91991fddf722309f5cd (patch)
tree4c8ccb62950871e7e48f8c5a9c90ba5ddd25d176 /CMakeLists.txt
parent57fd3b39c5f822a19906bcc3b987602099c8b790 (diff)
downloadlibwebsockets-1acf0b33c7386f4c5366e91991fddf722309f5cd.tar.gz
mbedtls: support older versions without net_sockets.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 471a8791..1b07f0e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2226,6 +2226,10 @@ endif()
CHECK_C_SOURCE_COMPILES("#define _GNU_SOURCE\n#include <unistd.h>\nint main(void) {int fd[2];\n return pipe2(fd, 0);\n}\n" LWS_HAVE_PIPE2)
+# old mbedtls has everything in mbedtls/net.h
+
+CHECK_C_SOURCE_COMPILES("#include <mbedtls/net_sockets.h>\nint main(void) { return 0;}\n" LWS_HAVE_MBEDTLS_NET_SOCKETS)
+
# tcp keepalive needs this on linux to work practically... but it only exists
# after kernel 2.6.37