aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOliver Langlois <olivier@olivierlanglois.net>2020-02-09 05:13:18 +0000
committerAndy Green <andy@warmcat.com>2020-02-21 17:32:41 +0000
commita404f5e95a40a97d978df2f2bd3b2435dbc628c7 (patch)
tree115fdb788fb751952a31049feea9d0659bce7963 /CMakeLists.txt
parentcbc8f0d9c0e8a872d9db2555dc914153237edb4b (diff)
downloadlibwebsockets-a404f5e95a40a97d978df2f2bd3b2435dbc628c7.tar.gz
unix plat: use eventfd in place of pipe where possible
From eventfd man page: Applications can use an eventfd file descriptor instead of a pipe (see pipe(2)) in all cases where a pipe is used simply to signal events. The kernel overhead of an eventfd file descriptor is much lower than that of a pipe, and only one file descriptor is required (versus the two required for a pipe).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4e36fd4..86924543 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -852,6 +852,7 @@ CHECK_FUNCTION_EXISTS(atoll LWS_HAVE_ATOLL)
CHECK_FUNCTION_EXISTS(_atoi64 LWS_HAVE__ATOI64)
CHECK_FUNCTION_EXISTS(_stat32i64 LWS_HAVE__STAT32I64)
CHECK_FUNCTION_EXISTS(clock_gettime LWS_HAVE_CLOCK_GETTIME)
+CHECK_FUNCTION_EXISTS(eventfd LWS_HAVE_EVENTFD)
if (NOT LWS_HAVE_GETIFADDRS)
if (LWS_WITHOUT_BUILTIN_GETIFADDRS)