aboutsummaryrefslogtreecommitdiff
path: root/lib/roles/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Green <andy@warmcat.com>2020-09-19 13:27:33 +0100
committerAndy Green <andy@warmcat.com>2020-09-21 12:47:11 +0100
commit62e566b9de7dff57f3fa43cc0f6fb373a0b513bb (patch)
treef132298cc13dd14bae5783a75cf66c700d5e87be /lib/roles/CMakeLists.txt
parent80388bf72d121fee60d559ecfe816db09781e8d7 (diff)
downloadlibwebsockets-62e566b9de7dff57f3fa43cc0f6fb373a0b513bb.tar.gz
client: move staged connect pieces into core-net
They have been in lib/roles/http for historical reasons, and all ended up in client-handshake.c that doesn't describe what they actually do any more. Separate out the staged client connect related stage functions into lib/core-net/client/client2.c: lws_client_connect_2_dnsreq() lib/core-net/client/client3.c: lws_client_connect_3_connect() lib/core-net/client/client4.c: lws_client_connect_4_established() Move a couple of other functions from there that don't belong out to tls-client.c and client-http.c, which is related to http and remains in the http role dir.
Diffstat (limited to 'lib/roles/CMakeLists.txt')
-rw-r--r--lib/roles/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/roles/CMakeLists.txt b/lib/roles/CMakeLists.txt
index f1f9d95d..3660f6b2 100644
--- a/lib/roles/CMakeLists.txt
+++ b/lib/roles/CMakeLists.txt
@@ -75,10 +75,9 @@ if (NOT LWS_WITHOUT_SERVER OR LWS_WITH_SECURE_STREAMS_PROCESS_API)
add_subdir_include_directories(listen)
endif()
-if (NOT LWS_WITHOUT_CLIENT)
+if (LWS_WITH_CLIENT AND (LWS_ROLE_H1 OR LWS_ROLE_H2))
list(APPEND SOURCES
- roles/http/client/client-http.c
- roles/http/client/client-handshake.c)
+ roles/http/client/client-http.c)
endif()
#