aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e39373bf..9be767fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -287,6 +287,11 @@ else()
set(LWS_WITH_NETLINK 0)
endif()
+if (${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
+ # its openssl has md5 deprecated
+ set(LWS_SUPPRESS_DEPRECATED_API_WARNINGS 1)
+endif()
+
#
# to use miniz, enable both LWS_WITH_ZLIB and LWS_WITH_MINIZ