aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 28bbdab6..b78c9ac5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -632,6 +632,11 @@ CHECK_C_SOURCE_COMPILES("#include <stddef.h>
return p != NULL;
}" LWS_HAS_GETOPT_LONG)
+CHECK_C_SOURCE_COMPILES("#include <linux/rtnetlink.h>
+ int main(void) {
+ int test = RTA_PREF;
+ return 0;
+ }" LWS_HAVE_RTA_PREF)
if (NOT PID_T_SIZE)
set(pid_t int)