aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Machata <pmachata@redhat.com>2012-01-05 18:07:02 +0100
committerPetr Machata <pmachata@redhat.com>2012-08-29 19:02:05 +0200
commit94078ecce3a103c28457e6f90f1e5b0dacc61146 (patch)
tree2067fe27ceac9f9cf166bd523f96e3a8e5e1d891 /Makefile.am
parent000e31195ad4ad30a0c80c93ab57a424e7d8d918 (diff)
downloadltrace-94078ecce3a103c28457e6f90f1e5b0dacc61146.tar.gz
Add expr.c, expr.h, plug in properly
- in callstack_pop, we don't free arch_ptr. That's because this doesn't get copied over the clone. It's a mere coincidence that fork() doesn't need to save register arguments, and this works. - added copyright notices to files that this touches. This is based on git blame. Only contributors of 10+ lines are added - test suite adjusted to not include "void" type as "don't show this int". Back ends in general need to know the exact type, so this never worked anyway.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ad93ef6..3c8cb25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,10 +30,11 @@ libltrace_la_SOURCES = \
library.c \
filter.c \
glob.c \
- vect.c \
type.c \
value.c \
- value_dict.c
+ value_dict.c \
+ expr.c \
+ vect.c \
libltrace_la_LIBADD = \
$(libelf_LIBS) \
@@ -73,7 +74,9 @@ noinst_HEADERS = \
vect.h \
type.h \
value.h \
- value_dict.h
+ value_dict.h \
+ expr.h \
+ vect.h \
dist_man1_MANS = \
ltrace.1