aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2014-01-07 21:00:44 +0100
committerPetr Machata <pmachata@redhat.com>2014-01-10 00:15:55 +0100
commitdfefa9f057857735a073ea655f5cb34351032c8e (patch)
treeb9f2d6815e8ea27e1af718450250a83f53379b47 /Makefile.am
parent6bcc092da6b7e20c6c2a9a5846536fbd3d77dbb8 (diff)
downloadltrace-dfefa9f057857735a073ea655f5cb34351032c8e.tar.gz
Add support for using elfutils as unwinder.
This adds support for using elfutils as unwinder with -w. Since elfutils 0.158 elfutils contains a simple unwinder interface that matches nicely on the ltrace backtrace support. The code reuses the libunwind infrastructure already in ltrace where possible (by defining HAVE_UNWINDER which is 1 if either libunwind or elfutils is used). It also reuses the ltrace proc_add_library callback to keep track of the ELF files mapped for the unwinder. The current implementation matches the output as if libunwind was used. But elfutils can also provide some more information since it can lookup the DWARF debuginfo. So if the source info of an address can be found through elfutils the backtrace will also include this as an additional output line per frame.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index efcf18a..ed469f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,7 @@ libltrace_la_LIBADD = \
$(liberty_LIBS) \
$(libsupcxx_LIBS) \
$(libstdcxx_LIBS) \
+ $(libdw_LIBS) \
$(libunwind_LIBS) \
sysdeps/libos.la