aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Machata <pmachata@redhat.com>2012-01-03 17:03:39 +0100
committerPetr Machata <pmachata@redhat.com>2012-08-29 19:02:05 +0200
commit000e31195ad4ad30a0c80c93ab57a424e7d8d918 (patch)
tree5cbadf5497d1ef87725561d74b4e193f2ec8ef48 /Makefile.am
parenta0a6a54a41d828c9a018829033443b0faabefb2f (diff)
downloadltrace-000e31195ad4ad30a0c80c93ab57a424e7d8d918.tar.gz
Add type.c/.h, value.c/.h, value_dict.c/.h
- none of this is plugged in yet - expr.c/.h is not in yet, so we still express array length with len_spec integer. Some function are mocked out so the thing compiles
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e91f71..ad93ef6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,7 +30,10 @@ libltrace_la_SOURCES = \
library.c \
filter.c \
glob.c \
- vect.c
+ vect.c \
+ type.c \
+ value.c \
+ value_dict.c
libltrace_la_LIBADD = \
$(libelf_LIBS) \
@@ -67,7 +70,10 @@ noinst_HEADERS = \
library.h \
filter.h \
glob.h \
- vect.h
+ vect.h \
+ type.h \
+ value.h \
+ value_dict.h
dist_man1_MANS = \
ltrace.1